Estruturas de Seleção

De Wikiunicentro
Ir para: navegação, pesquisa

Estruturas de Seleção

É uma estrutura de desvio do fluxo de controle presente em linguagens de programação que realiza diferentes computações ou ações dependendo se a seleção (ou condição) é verdadeira ou falsa. Assista a videoaula sobre este tipo de estrutura aqui.

Sintaxe:

Pseudocódigo            
                        
Se (condição) Então     
   (bloco de código)    
FimSe                   
________________________

Pascal                  

if(condição) then
   begin
      (bloco de código)
   end;
________________________

Linguagem C             

if(condição){
   (bloco de código)
}
________________________

Phyton
     
if condição:   
   (bloco de código)
                        
________________________

C++

if(condição){
   (bloco de código)
}
                  

Exemplo:
Verificar e apresentar se x é par ou impar.
var x : Inteiro.

Pseudocódigo           
                       
Se (x mod 2 = 0) Então 
   escreva('PAR');     
Senão                  
   escreva('IMPAR');   
FimSe                  
________________________

Pascal               

if(condição) then    
   begin             
      write('PAR')   
   end               
else                 
   begin             
      write('IMPAR') 
   end;              

________________________

Linguagem C          

if(x % 2 == 0){      
   printf("PAR");    
}else{               
   printf("IMPAR");  
}
________________________

Phyton

if x% 2 == 0:
   print('PAR');
else
   print('IMPAR');
________________________

C++          

if(x % 2 == 0){      
  cout << "PAR";    
}else{               
  cout << "IMPAR";
}

Exemplo

Gangorra - 2455

#include <stdio.h>
#include <stdlib.h>

int main(){
   int pesoCrianca1 = 0, comprimento1 = 0, pesoCrianca2 = 0, comprimento2 = 0;

   scanf("%d %d %d %d", &pesoCrianca1 , &comprimento1, &pesoCrianca2, &comprimento2);

   if(pesoCrianca1 * comprimento1 == pesoCrianca2 * comprimento2){
      printf("0\n");
   }else{
      if(pesoCrianca1 * comprimento1 < pesoCrianca2 * comprimento2){
         printf("1\n");
      }else{
         printf("-1\n");
      }
   }
}


Problemas

Quer mais?