Estruturas de Seleção

De Wikiunicentro
Ir para: navegação, pesquisa

Estruturas de Seleção

É uma estrutura de desvio do fluxo de controle presente em linguagens de programação que realiza diferentes computações ou ações dependendo se a seleção (ou condição) é verdadeira ou falsa. Assista a videoaula sobre este tipo de estrutura aqui.

Sintaxe:

Pseudocódigo            | Pascal                   | Linguagem C             | Phyton
                        |                          |                         |
Se (condição) Então     | if(condição) then        | if(condição){           | if condição:
   (bloco de código)    |    begin                 |    (bloco de código)    |    (bloco de código)
FimSe                   |       (bloco de código)  | }                       |
                        |    end;                  |                         |
                                                  

Exemplo:
Verificar e apresentar se x é par ou impar.
var x : Inteiro.

Pseudocódigo           | Pascal               | Linguagem C          | Phyton
                       |                      |                      |
Se (x mod 2 = 0) Então | if(condição) then    | if(x % 2 == 0){      | if x % 2 == 0:
   escreva('PAR');     |    begin             |    printf('PAR');    |    print('PAR');
Senão                  |       write('PAR')   | }                    | else 
   escreva('IMPAR');   |    end               | else{                |    print('IMPAR');
FimSe                  | else                 |    printf('IMPAR');  |          
                       |    begin             | }                    |               
                       |       write('IMPAR') |                      |
                       |    end;              |                      |




Problemas