BrOffice

De Wikiunicentro
Ir para: navegação, pesquisa

Índice

CALC

Como inserir dados e planilhas do Calc, como tabelas, em documentos do Writer

Quando copiados do BrOffice.org Calc e colados no BrOffice.org Writer os dados e/ou tabelas são incorporadas como objetos no BrOffice.org Writer. Quando colados dessa forma, para sua edição a tabela é aberta no BrOffice.org Calc, sendo que a mesma não fica com a formatação semelhante a formatação da tabela feita no próprio BrOffice.org Writer, o que prejudica a formatação dos documentos.

Para contornar este problema, selecione e copie os dados do BrOffice.org Calc e no BrOffice.org Writer acione o menu Editar – Colar Especial e selecione Link DDE e após clique no botão Ok. Dessa forma, os dados são inseridos no BrOffice.org Writer em uma tabela com formatação semelhante as tabelas feitas no próprio software.

Porém, essa tabela está vinculada ao arquivo de origem, ou seja o arquivo do BrOffice.org Calc com os dados originais e qualquer alteração feita neste arquivo do BrOffice.org Calc ocasionará alteração na tabela do BrOffice.org Writer.

Para evitar que isso ocorra, após inserir a tabela, acione o menu Editar – Vínculos aparecerá uma janela que contém o caminho dos arquivos vinculados. Selecione o caminho e acione Desvincular, assim o link entre o arquivo de origem e o documento atual será quebrado e as tabelas não serão mais modificadas pela alteração do arquivo original.


CALC - Vínculos em Arquivos Compartilhados (Linux e Windows)

CALC - Vínculos - Preparando ambiente

Objetivo:

     Fornecer informações técnicas de implementação e utilização do recurso de vínculo, disponível no calc, para documentos que serão acessados por diversos usuários em rede através dos sistemas operacionais linux e windows.


Considerações iniciais:

- A função de vínculos do CALC funciona perfeitamente quando a edição ocorre somente em uma estação da rede.

- Quando é necessário o acesso em rede ao documento matriz, alguns padrões precisam ser seguidos para que não ocorra a quebra de vínculos.

- A função DDE não funciona entre os ambientes linux e windows, devido a forma como cada um trata esta função.


Implementação:

  • 1) Colocar todos os documentos (matriz e vínculos) em um diretório de rede, preferencialmente no servidor de arquivos.

  • 2) Nas estações windows mapear esta pasta de rede na unidade "V:".

WikiVinculoArquivos1.jpg

  • 3) Nas estações linux criar um diretório "V:" com permissão 777 no diretório raiz (/).

  • 4) Ainda nas estações linux acrescentar no arquivo "/etc/security/pam_mount.conf.xml" as informações para montar a pasta de rede no diretório "/V:"

  • 5) Configurar os vinculos no BrOffice da seguinte forma:

- Abra o documento matriz, escolha a célula que receberá o vinculo e clique em = (igual)

- Abra o documento que será usado para fornecer os valores, selecione a célula com o valor e pressione ENTER.


  • 6) Para atualizar os vinculos automaticamente, uma alternativa é criar uma macro:

Acesse o menu Ferramentas -> Macros -> Organizar Macros -> LibreOffice.org Basic...
WikiVinculoArquivos2.jpg


Clique em "Minhas macros -> Standard". No campo "Nome da macro" digite "Reler" e clique em "Novo":
WikiVinculoArquivos3.jpg


Na tela de edição da macro, adicione o código da macro conforme o sistema operacional:
WikiVinculoArquivos4.jpg


Windows:

sub Reler

rem ----------------------------------------------------------------------
rem define variables
dim document as object
dim dispatcher as object

rem ----------------------------------------------------------------------
rem get access to the document
document = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Save", "", 0, Array())

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Reload", "", 0, Array())

end sub



Linux:

sub Reler
rem ----------------------------------------------------------------------
rem define variables
dim document as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Save", "", 0, Array())

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Reload", "", 0, Array())

rem ----------------------------------------------------------------------
rem dispatcher.executeDispatch(document, ".uno:UpdateTableLinks", "", 0, Array())

end sub



  • 7) Para facilitar a execução da macro recém criada, adicione ela à barra de tarefas.

Acesse o menu "Exibir -> Barras de ferramentas -> Personalizar":
WikiVinculoArquivos5.jpg


Na guia "Barras de ferramentas" clique em "Adicionar":
WikiVinculoArquivos6.jpg


Localize na lista "Macros do LibreOffice.org -> Minhas macros -> Standard -> Module1 -> Reler". Clique em "Adicionar":
WikiVinculoArquivos7.jpg


Devolta à janela "Personalizar", selecione "Reler" e clique em "Modificar -> Alterar ícone":
WikiVinculoArquivos8.jpg]


Escolha um ícone que represente a opção reler:
WikiVinculoArquivos9.jpg]


Pronto, um atalho para a macro será disponibilizado na barra principal:
WikiVinculoArquivos10.jpg


  • 8) LEMBRE-SE: Antes de fazer a atualização dos vínculos, esta macro salva as alterações atuais do documento!



Como apagar linhas repetidas em uma planilha do Calc

Às vezes, temos uma planilha no BrOffice.org Calc com algumas linhas repetidas, mas precisamos desses dados sem nenhuma duplicação. Qual a forma mais prática de apagar linhas repetidas em uma planilha no BrOffice.org Calc? Os passos abaixo fornecem uma maneira:

  1. Selecione a área com os dados que você quer excluir os duplicados;
  2. Acesse menu Dados >> Filtro >> "Filtro padrão...";
  3. Na janela que é aberta, o rótulo da primeira ou última coluna deverá aparecer no item "Nome do campo", mude isso para "-nenhum-";
  4. Clique no botão "Mais". Então marque a opção "Sem duplicação";
  5. Marque a opção "Copiar resultado para...". Clique no botão com uma seta verde (se você posicionar o mouse em cima ele mostra o nome "Encolher"), então selecione uma célula para onde deseje copiar os dados, pode ser na mesma folha de planilha ou em outra folha. Após isso, clique no botão "Encolher" novamente, para voltar a janela anterior. Então clique em "OK". Os dados não repetidos serão copiados para onde você determinou.


WRITER

WRITER - Como fazer numeração de páginas

Uma numeração de páginas pode envolver as seguintes situações:

1 – Numeração sequencial simples: Numeração sequencial normal feita a partir da 1° página.

2 – Numeração sequencial sem a primeira página: Situação muito usada quando desejamos colocar a 1ª página sem cabeçalho ou rodapé para capa de trabalhos escolares ou profissionais.

3- Numeração sequencial a partir de outra página: Situação muito usada quando não queremos que um número determinado de páginas esteja numerada, mas queremos que a numeração apareça a partir de uma outra página, continuando a sequência normal.

4 – Numeração sequencial a partir de outra página, ignore um determinado número da página: Muito comum em trabalhos de monografia onde algumas páginas não são levadas em consideração para a contagem das páginas. O que faz com que o total de páginas seja diferente do número de páginas numeradas.

Este tutorial tem por objetivo auxiliar os usuários do OpenOffice a personalizar seus documentos no que diz respeito a numeração de páginas levando em consideração os casos mencionados.

OBS 1 : Um elemento novo para aqueles que estão começando a trabalhar com o OpenOffice é o uso de Estilos. Quando queremos alterar o comportamento padrão de alguma coisas no OpenOffice temos que usar Estilos. Para o nosso caso, em várias situações vamos recorrer ao uso, ou criação, de Estilos de Páginas.

OBS 2 : Para não aparecer a numeração na 1ª página, ou em qualquer outra, é necessário que o Rodapé ou o Cabeçalho não apareçam na página. Esse conceito vai valer para todas as outras alterações que vamos fazer

1 – Numeração sequencial simples:

Para fazer uma numeração simples de páginas, basta apenas que se insira um cabeçalho ou rodapé e coloque a numeração de página na posição desejada.

Para isso vá em Inserir > Rodapé (ou Cabeçalho) > Padrão. Dentro do Rodapé (ou Cabeçalho) Coloque o cursor na posição em que se deseja. Vá em Inserir > campos Número de Página. A numeração irá aparecer automaticamente em todas as páginas criadas em seus documentos.

2 – Numeração sequencial sem a primeira página:

Para não aparecer a numeração na 1ª página você pode usar duas opções: a) Usar um Estilo pronto no OpenOffice chamado Primeira Página, ou b) Criar uma quebra de página a partir da 2ª pagina.

a)Para usar o Estilo chamado Primeira Página, basta apenas que se faça o seguinte, em Formatar > Estilos e Formatação, irá abrir uma janela com os Estilos disponíveis para uso no OpenOffice. Nos botões disponíveis, clique em Estilos de página. Escolha o estilo Primeira Página, clicando duas vezes no estilo. Imediatamente irá sumir o cabeçalho e rodapé na primeira página.

b) Para usar uma quebra de página, faça o seguinte: Coloque o cursor no final da página 1. Vá em Inserir > Quebra Manual. Deixe marcado a opção Quebra de página. Em Estilo, escolha Índice. Clique em Ok. Agora, vá em Inserir > Rodapé (ou Cabeçalho) > índice, e coloque a numeração a partir da página 2.

3- Numeração sequencial a partir de outra página.</p>

Para fazer com que a numeração de página apareça apenas a partir de uma outra página qualquer, faça o seguinte: Coloque o cursor no final da página anterior a que se vai numerar, ou seja, se quero numerar a partir da página 10, coloco o cursor no final da página 9. Vá em Inserir > Quebra Manual. Deixe marcado a opção Quebra de página. Em Estilo, escolha Índice. Clique em Ok. Agora, vá em Inserir > Rodapé (ou Cabeçalho) > índice, e coloque a numeração nas página em que estão os cabeçalhos e rodapés.

4 – Numeração sequencial a partir de outra página, ignore um determinado número da página:

Para fazer com que a numeração de página ignore um determinado número da página, faça o seguinte: Coloque o cursor no final da página anterior a qual deseja numerar, ou seja, se quero numerar a partir da página 10, coloco o cursor no final da página 9. Vá em Inserir > Quebra Manual. Deixe marcado a opção Quebra de página. Em Estilo, escolha Índice. Marque a opção Alterar número de página. Clique em Ok. A numeração da página desejada irá sumir, sendo assim para que a posterior a essa continue com a numeração corrente coloque o cursor no final da página sem numeração e vá em Inserir > Quebra Manual escolha Quebra de Página e no estilo marque Padrão, logo abaixo marque a opção Alterar Número de Página e coloque o número a partir do qual deseja. Seguindo o exemplo acima seria a partir da página 11.

Paginação para monografias

Inserir texto não-formatado aqui exemplo para uso: Meu trabalho de monografia possui:

1ª página: Capa

2ª página: Contra-capa

3ª página: Agradecimentos

4ª página: Resumo

5ª página: Sumario

6ª página: Lista de Figuras

7ª página: Lista de Tabelas

8ª página: Introdução

9ª página em diante restante do trabalho...

Onde:

1ª e 2ª páginas não recebem numeração, mas são contadas.

3ª a 7ª paginas recebem numeração romana, com inicio em III (3)

3ª a 7ª paginas recebem numeração romana, com inicio em III (3)

8ª página em diante são numeradas com algarismos arábicos, com inicio em 1.

Vamos criar mais dois estilos, um que conterá a numeração Romana e outro que conterá a numeração Arábica para todo o restante do trabalho, foi necessário criar um estilo para a numeração arábica (1,2,3) para não misturar com o estilo Padrão, que servirá para Capa e Contracapa.

Então os estilos ficarão assim:

Página 1 e 2 : estilo Padrão

Página 3 a 7 : estilo Romana

Página 8 até o final : estilo Arábica

Abra o documento que deseja paginar, em seguida vá no menu clique "Formatar" clique em "Estilos e formatação" ou pela tecla de atalho F11, na janela que irá abrir clique no ícone de “Estilos de página”.

Wikipaginacao1.jpg

Definindo estilo Romano:

Clique com o botão direito em "Estilo Padrão" e logo em seguida em "Novo...":

Wikipaginacao11.jpg

Na janela que irá abrir na aba “Organizador” defina o Nome "Romana", e na opção "Proximo estilo" também coloque "romana". Na aba “Página” em "definições de layout" na opção "formato" coloque numeração romana(I,II,III), clique em OK.

Wikipaginacao2.jpg Wikipaginacao3.jpg


Inserindo numeração romana (i, ii, iii, iv):

Coloque o cursor no ultimo caractere da página anterior à página que vai receber a numeração romana. Vá no menu "Inserir" clique em "Quebra Manual", na opção "Tipo" escolha "Quebra de página" e na opção "Estilo" escolha "Romana", marque a caixa "Alterar número de página" e escolha a numeração adequada (no meu caso 3), clique em OK.


Wikipaginacao5.jpg


Vá no menu "Inserir" clique em "Rodapé->Romana":

Wikipaginacao6.jpg


Vá no menu "Inserir" clique em "Campos->Numero de pagina" e pronto:

Wikipaginacao7.jpg





Definindo estilo Arábico:

Abra o documento que deseja paginar, em seguida vá no menu clique "Formatar" clique em "Estilos e formatação" ou pela tecla de atalho F11, na janela que irá abrir clique no ícone de “Estilos de página”.

Wikipaginacao1.jpg


Clique com o botão direito novamente em "Estilo Padrão" e clique em "Novo...":

Wikipaginacao11.jpg

Na janela que irá abrir na aba “Organizador” defina o nome "Arabica", e na opção "Proximo estilo" também coloque "Arábica", clique em OK. (Na aba "Página" em "definições de layout" na opção "formato" por padrão a numeração é arábica, não sendo necessário alterar).

Wikipaginacao4.jpg


Inserindo numeração arábica (1, 2, 3, 4):

Coloque o cursor no ultimo caractere da página anterior à página que irá receber a numeração arábica. Vá no menu "Inserir" clique em "Quebra Manual", na opção "Tipo" escolha "Quebra de página" e na opção "Estilo" escolha "Arabica", marque a caixa "Alterar número de página" e escolha a numeração adequada (no meu caso 3). clique em OK.


Wikipaginacao8.jpg


Vá no menu "Inserir" clique em "Rodapé->Arabica":

Wikipaginacao9.jpg

Vá no menu "Inserir" clique em "Campos->Numero de página" e pronto:

Wikipaginacao7.jpg

Mala Direta com o BrOffice

Para se criar uma mala direta no BrOffice.org primeiramente deve-se ter uma fonte de dados registrada. Essa fonte de dados, pode ser um arquivo de texto, uma planilha do BrOffice.org Calc, arquivo Dbase, arquivo do Access, banco de dados (MySql, JDBC, Adabas, Oracle, etc.) entre outras. Arquivos .doc de mala direta do Microsoft Office não podem ser utilizados diretamente para a criação de mala direta no BrOffice.org. Entretanto, esses arquivos .doc podem ser convertidos facilmente em uma planilha do BrOffice.org Calc e assim utilizados como mala direta do BrOffice.org. Essa conversão, de maneira sucinta, pode ser feita através da seleção de toda a tabela do arquivo de mala direta do arquivo em .doc (o qual pode ser aberto através do Microsoft Office ou pelo BrOffice.org Writer), copiada para a memória (Ex. através da tecla de atalho CTRL-C) e colada em uma planilha em branco de um documento do BrOffice.org Calc (Ex. através da tecla de atalho CTRL-V).

Criação da mala direta

A criação da mala direta é realizada através do Assistente de Mala Direta, vá em arquivo -> novo -> banco de dados

Fig1.jpg

Com o Assistente de mala direta aberto, deve-se selecionar a opção planilha e prosseguir.

Fig2.jpg

Na próxima etapa procure a planilha desejada, prossiga e selecione as opções conforme a figura a seguir e conclua essa etapa do trabalho.

Fig4.jpg

Na segunda etapa, abra o libre office writer para iniciar a criação das etiquetas. Vá em arquivo -> novo -> etiquetas

Fig5.jpg

Na aba etiquetas, localize na opção Banco de dados a planilha que salvou anteriormente. Em tabela selecione Planilha1. Posteriormente, ainda na aba etiquetas, deve-se digitar no quadro branco os dados(TEXTO DA ETIQUETA), na mesma ordem em que se apresentavam na planilha, neste caso, foi dogitado nome dado um espaço e inserido através da opção campo de banco de dados da etapa 3 grifada na figura, os dados do arquivo da mala direta. Em fabricante e tipo escolha pimaco.

Fig8.jpg

Caso não exista o assistente pimaco em seu computador clique na aba formato e configure manualmente os campos solicitados conforme ilustração abaixo. Ao terminar clique em salvar e digite pimaco no campo do fabricante.

Fig9.jpg

Na aba opções deve-se selecionar os campos conforme figura a seguir. Para finalizar clique em novo documento.

Fig14.jpg

Abrirá um esboço das etiquetas, a partir disso selecione a primeira etiqueta, dê dois espaçõs e coloque em formato verdana, tamanho 08. Clique em sincronizar etiquetas para que fiquem todas iguais.

Fig15.jpg

Antes de imprimir vá em formatar -> página. Na aba página selecione em bandeja de papel a opção papel manual, dê ok. Essa opção serve para que se imprima na bandeja manual, o mais indicado.

Fig11.jpg

Para imprimir vá em arquivo -> imprimir e na janela que abrirá clique em sim(FORNECERÁ O BANCO DE DADOS) em seguida dê um ok e selecione a impressora de sua preferência.

Fig16.jpg

Fig17.jpg

Para finalizar, na próxima vez que for utilizar a mala direta, você pode contar com a ajuda de uma opção que fica em editar -> trocar banco de dados. Dessa maneira, será desnecessário refazer toda vez esse procedimento, já que o assistente troca a planilha.

Fig12.jpg

BrOffice.org / MsOffice – algumas perguntas frequentes

Em minha empresa, sempre surgem problemas com formatos de arquivos do MS-Office e do BrOffice. Qual a forma correta de tratar essa questão?

Esta questão requer um embasamento conceitual, afim de evitar o simples “adestramento”, infelizmente, tão comum entre os usuários de sistemas informatizados. Todos os conceitos abaixo se referem ao Microsoft Office até a versão 2003. A versão 2007 mudou completamente o seu formato de arquivos, como é de praxe ocorrer entre as diferentes versões deste software por questões mercadológicas (forçar o usuário a mudar de versão).

Formato de arquivos BrOffice.org x MS-Office

Um formato de arquivo eletrônico especifica como são organizados internamente os dados (texto, figuras, tabelas, etc) e as instruções de como recuperá-las, afim de possibilitar sua exibição em um monitor de vídeo, ou enviar para uma impressora.

Padrões fechados x padrões abertos

Este formato pode ser exclusivo e considerado “segredo” de um fornecedor, ou pode ser aberto, seguindo padrões internacionais, como as normas da ISO.

No caso dos pacotes de software para aplicações de escritório (Office suites), a Microsoft adota o primeiro modelo, ou seja, um formato de arquivo fechado que só ela conhece e não divulga, já o BrOffice.org, OpenOffice.org, StarOffice, Koffice, Lotus Symphony, etc, utilizam-se de um formato aberto padronizado internacionalmente através da norma ISO/IEC 26300 e conhecido como OpenDocumentFormat, ou ODF. Esta mesma norma tem sua correspondente brasileira, a NBR ISO 26300, elaborada pela ABNT (Associação Brasileira de Normas Técnicas) e específica para formatos de arquivos de software para escritório (texto, planilha eletrônica, slides de apresentação, gráficos vetoriais, fórmulas matemáticas e banco de dados).

Em princípio, usar um formato de arquivos da Microsoft, implica automaticamente em usar compulsoriamente um software da empresa. Ou seja, você tem que pagar para a Microsoft para poder ver e editar seus próprios dados. Na prática é um pouco diferente.

Através de processos de engenharia reversa, descobriu-se uma grande quantidade de detalhes do formato do arquivo da Microsoft, possibilitando assim, a outros softwares, tais como o BrOffice.org, poderem abrir e salvar arquivos neste formato com um bom nível de compatibilidade, que no entanto não chega a ser de 100%.

Os governos do mundo inteiro e o setor público de forma geral, iniciaram um esforço nos últimos anos no sentido de utilizar apenas padrões abertos, atendendo, assim, a princípios de preservação dos documentos públicos (como abriríamos um arquivo no formato da Microsoft daqui a 50 anos se a empresa, por exemplo, não existir mais ou não der mais suporte ao formato utilizado?) e de acessibilidade pelo cidadão a estes documentos, que no modelo fechado, para exercer seu direito, é obrigado a pagar uma taxa (adquirir o MS-Office custa mais de R$1.000,00 e pirataria é crime) a uma empresa privada para acessar documentos públicos.

Entendendo as extensões do nome dos arquivos, o formato dos arquivos, geralmente, pode ser reconhecido através das últimas três letras do seu nome, e que são separadas das demais através de um ponto. Estas últimas letras também são conhecidas como extensão ao nome do arquivo.

Tomemos como exemplo, um arquivo denominado notas_alunos.doc. A extensão doc refere-se a um arquivo que usa o formato de arquivo de texto do software Microsoft Word. Já um arquivo notas_alunos.odt, refere-se a um arquivo de texto do BrOffice.org-Writer (extensão odt). Continuando… um arquivo notas_alunos.xls refere-se a um arquivo da planilha eletrônica MS-Office Excel, ao passo que um arquivo notas_alunos.ods refere-se a um arquivo da planilha eletrônica do BrOffice.org – Calc.

A seguir um quadro relacionando os formatos de arquivos do BrOffice.org e do MS-Office:

Broffice formatos.jpg

Interoperabilidade entre os formatos da Microsoft e do BrOffice.org

Apesar do formato de arquivos da Microsoft ser fechado e sempre foi considerado “segredo”, através de técnicas de engenharia reversa, foi possível criar softwares que conseguem abrir e salvar arquivos neste formato. É certo que não há 100% de compatibilidade, havendo perdas quanto à formatação, especialmente se estivermos lidando com documentos relativamente complexos.

De forma geral podemos estabelecer os seguintes princípios:

  • O MS-Office não consegue ler os arquivos gerados no formato nativo do BrOffice.org (odt, ods, odp);
  • O BrOffice.org consegue ler e gravar arquivos no formato do MS-Office (doc, xls, ppt), com bom nível de compatibilidade.


O BrOffice.org pode, inclusive, ser configurado para operar diretamente com os formatos de arquivos do MS-Office, sem ser necessário recorrer ao menu Arquivo >> Salvar como…, porém, isto não é recomendado. Lembre-se! Não há 100% de compatibilidade entre os formatos dos arquivos e operar dessa forma, alternando os arquivos entre as duas aplicações, com certeza é a forma mais eficaz de “arrumar dor de cabeça” em algum momento. A recomendação é a seguinte:

  • Utilize a capacidade que o BrOffice.org tem de ler os arquivos gerados pelo MS-Office, mas salve-os em seguida no formato nativo do mesmo (odt, ods, odp) e a partir daí utilize preferencialmente este formato, ou utilize o plugin Multisave para o BrOffice.org, que salva simultaneamente nos formatos doc, odf e pdf.
  • Oriente os professores e demais interessados, para que sempre deem preferência ao formato aberto padrão ISO (utilizado pelo BrOffice.org), e que podem instalar o BrOffice.org de forma legal e segura, também em seus computadores pessoais mesmo que utilizem o Windows. Basta baixar o software de http://www.broffice.org/
  • Oriente à quem esteja utilizando o MS-Office 2007, para que altere a configuração do programa, afim de que seja utilizado o formato doc, xls e ppt ao invés do formato docx, xlsx, pptx.

Linux educacional – Convivendo com os diferentes formatos no dia-a-dia

Infelizmente, até que todos se conscientizem da importância de usar apenas padrões abertos, teremos que conviver com a multiplicidade de formatos. Felizmente, não é necessário ser “cientista da Nasa” para gerenciar esta situação. A seguir, mostramos algumas práticas que, possivelmente, cobrem suas necessidades diárias.

Recomendações e informações finais

  • Se for necessário trocar arquivos entre diferentes sistemas, e estes arquivos não precisarem ser editados, ou seja, a única finalidade é que sejam lidos ou impressos, o melhor formato de arquivo a utilizar é o PDF.
  • Este tipo de arquivo é totalmente independente de sistema ou software, reproduzindo com exatidão, inclusive os diversos tipos de caracteres, mesmo que não existam no sistema aberto.
  • O formato PDF também é padronizado internacionalmente (norma ISO/IEC 32000).
  • O BrOffice.org já possui o recurso de exportar arquivos de qualquer de seus componentes (texto, planilha ou slides), para o formato PDF. Com o arquivo a ser exportado aberto, basta clicar em: Arquivo >> Exportar como PDF… >> Exportar >> Exportar
  • Para dotar o MS-Office (e todas as outras aplicações do Windows) de recurso semelhante, pode ser instalado o software PDF Creator disponível em: http://sourceforge.net/projects/pdfcreator/. Este software é livre e gratuito, podendo ser instalado e usado livremente em qualquer local e para qualquer fim. Este software cria uma impressora virtual no Windows, de forma que, para fazer a conversão de qualquer arquivo para PDF, basta carregá-lo e mandar imprimir através do diálogo completo (Arquivo >> Imprimir >>…), escolhendo a “impressora” PDF Creator.
  • Anteriormente, afirmou-se que o MS-Office não tem a capacidade de ler e gravar arquivos no formato nativo do BrOffice.org. Na verdade, isto é possível sim, desde que se instale o plugin produzido pela empresa Sun Microsystems e que está disponível em: http://www.sun.com/software/star/odf_plugin/get.jsp e serve para as versões do Ms-Office 2000, XP, 2003 e 2007. Recentemente a Oracle, que adquiriu a Sun Microsystems, passou a cobrar – muito caro – por uma cópia desse plugin, já que, para a empresa é antieconômico oferecer um plugin para um software concorrente do StarOffice – versão paga do OpenOffice.org/BrOffice.org – oferecida pela Oracle. No entanto, vale o que já foi dito anteriormente quanto à compatibilidade: ela não de 100%, embora não esteja tão longe assim desse ponto.
  • Recomenda-se fortemente aconselhar a usuários do Microsoft Office 2007 que alterem a configuração do programa afim de gerar arquivos no mesmo formato do MS-Office 2003, sob pena de terem muitos problemas na troca de arquivos, inclusive com outros usuários de MS-Office de versões anteriores, e que são a ampla maioria no mercado.

Fonte:
ESTADO DE SANTA CATARINA
SECRETARIA DE ESTADO DE DESENVOLVIMENTO REGIONAL
GERÊNCIA REGIONAL DE EDUCAÇÃO
NTE – Núcleo de Tecnologia Educacional

JARAGUÁ DO SUL/SC