Estruturas de Repetição

De Wikiunicentro
Ir para: navegação, pesquisa

Estruturas de Repetição

As estruturas de repetição também são conhecidas como laços (loops) e são utilizados para executar, repetidamente, uma instrução ou bloco de instrução enquanto determinada condição estiver sendo satisfeita. Assista a videoaula sobre este tipo de estrutura aqui.

As principais formas de implementar o loop são o enquanto (ou while) e o para de até (ou for).

Sintaxe enquanto:

Pseudocódigo             | Pascal                  | Linguagem C          | Python 
                         |                         |                      |
Enquanto (condição) Faça | while (condição) do     | while(condição){     | while(condição):
   (bloco de código)     |    begin                |    (bloco de código) |    (bloco de código)
Fim Enquanto             |       (bloco de código) | }                    |
                         |    end;                 |                      |

Exemplo enquanto:

Um loop que apresenta até o numero 10.
var i : Inteiro.

Pseudocódigo             | Pascal                  | Linguagem C          | Python 
                         |                         |                      | 
i = 1;                   | i := 1;                 | i = 1;               | i = 1;
                         |                         |                      |
Enquanto (i <= 10) Faça  | while (i <= 10) do      | while(i <= 10){      | while(i <= 10):
   escreva(i);           |    begin                |    printf("%d",x);   |    print(i);
   i = i + 1;            |       writeln(i);       |    i = i + 1;        |    i = i + 1;
Fim Enquanto             |       i:= i+1;          | }                    |
                         |    end;                 |                      |


Sintaxe para de até:

Pseudocódigo

Para (variavel) de (valor inicial) ATÉ (valor final) passo (incremento) faça  
   (bloco de código)
Fim Para            
__________________
Pascal

FOR (variável):=(valor inicial) to (valor final) do	
   begin
      (bloco de código)
   end;
__________________
Linguagem C
for(variável = valor inicial; variável <= valor inicial; variável = variável + 1){
      (bloco de código)
}
__________________
Python

for x in range(valor inicial , valor final):
   (bloco de código)

Exemplo para de até:

Um loop que apresenta até o numero 10.
var i : Inteiro.

Pseudocódigo                 | Pascal                | Linguagem C                     | Python
                             |                       |                                 |
Para i de 1 ATÉ 10 + 1 faça  | FOR i:=1 to 10 + 1 do | for(i= 1; i <= 10 ; i = i + 1){ | for i in range(1 , 10 + 1):
    escreva(i);              |    begin              |    printf("%d",i);              |       print(i);
Fim Para                     |       escreva(i);     | }                               |
                             |    end;               |                                 |

Note que usando o enquanto dispensamos o incremento da variavel controladora dentro do bloco de código, esse incremento é definido na assinatura loop.

Problemas